You are not logged in.

Dear visitor, welcome to Nitrado Türkiye Ön Ödemeli Gameserver Kiralama Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Pluginer

Intermediate

  • "Pluginer" is male
  • "Pluginer" started this thread

Posts: 1,062

Date of registration: Feb 20th 2016

Location: Modena, Italya

Occupation: Öğrenci

  • Send private message

1

Monday, August 29th 2016, 4:16pm

Sunucu çökertme (crash) sorunu çözümü [ 1.8 ] [Denenmiştir]

Bir kaç ay önce yeni bir saldırı clientin ortaya çıktığını söylemiştim, ve bu client ile sunucu çökertilebiliniyordu.
Ve sonunda bunun korumasını buldum.

Koruması:

Korumasını bir plugin ile çözmüş olduk, pluginin adı ViaVersion.
Bazı hub sunucuların kullandığı bir plugindir.

Bu plugin neye yarıyor?

Bu pluginin amacı sunucunuza yeni versiyon girişleri açmaktır.
bu client 1.8 versiyonunda çalışıyor, eğer sunucunuz 1.8.x versiyon değil ise bu plugini kurmanıza gerek yok.
Plugini kurduğunuzda 1.9.x ve 1.10.x girişleri açılacaktır.

Peki bu pluginin koruma ile ne alakası var?

Pluginde packet limit mevcut, 100'den fazla packetler kullanlmıyor.
Ve bu clientte 100 packet gönderirseniz sunucuda 1 saniyelik bile lag olmuyor. Anca 1milyon packet gönderirseniz lag oluyor.
Ve ViaVersion 100'den fazla packet kabul etmediği için o oyuncuyu oyundan atıcaktır. (Aynı PaperSpigottaki gibi)

Plugini nasıl yüklerim?

Sunucunuzu durdurun.
Panelinizdeki plugins klasörünü açınız.
ViaVersion adlı plugini sunucunuza yükleyiniz.
Sunucunuzu yeniden başlatınız.

Ve şuan plugin kuruldu, hem 1.9.x ve 1.10.x girişleri açıldı, hemde koruması aktif oldu.

Plugin link:


Sorularınız ve ya sorunlarınız varsa bu konunun altına yazabilirsiniz.
Herkese Iyi Günler.

Java, Developer

Epidemides

Intermediate

  • "Epidemides" is male
  • "Epidemides" has been banned

Posts: 733

Date of registration: Aug 6th 2016

Location: Turkiye/NitradoTR

Occupation: Öğrenci

  • Send private message

2

Monday, August 29th 2016, 4:21pm

Keşke Videolu olarak Gösterseydin (: yinede teşşekürler.
Bizde Kadere İman Sorgusuz.

Pluginer

Intermediate

  • "Pluginer" is male
  • "Pluginer" started this thread

Posts: 1,062

Date of registration: Feb 20th 2016

Location: Modena, Italya

Occupation: Öğrenci

  • Send private message

3

Monday, August 29th 2016, 4:23pm

olabilir, ama gerek duymadım.
plugini kurmanız yetiyor zaten.
Java, Developer

  • "MD_Optional" is male
  • "MD_Optional" has been banned

Posts: 580

Date of registration: Mar 6th 2016

  • Send private message

4

Monday, August 29th 2016, 4:46pm

Sunucu 1.7 - 1.8 Kullanabilirmiyim ?
Bide Sunucu Nasıl Cöküyor Bir Versiyon Ile Giriyorlar Komut Yazıyorlar Cöküyor Öylemi ?
ITRADO ORUM

Pluginer

Intermediate

  • "Pluginer" is male
  • "Pluginer" started this thread

Posts: 1,062

Date of registration: Feb 20th 2016

Location: Modena, Italya

Occupation: Öğrenci

  • Send private message

5

Monday, August 29th 2016, 4:54pm

Evet. Bir client ile giriyorlar bir komut yazıp çökertiyorlar.
1.7 - 1.8'de çalışırmı bilmiyorum, ama pluginin 1.7 versiyonu yok zaten.
Yani çalışmaz, ya sunucunuzu 1.7 yapın yada 1.8.
Unutmayın, 1.11 snapshot'u çıktı. 4-5 aya 1.7 devri bitecek.
Java, Developer

Pluginer

Intermediate

  • "Pluginer" is male
  • "Pluginer" started this thread

Posts: 1,062

Date of registration: Feb 20th 2016

Location: Modena, Italya

Occupation: Öğrenci

  • Send private message

6

Sunday, September 11th 2016, 8:07pm

Yeni koruma:

NoCheatPlus plugininin en son sürümünü buraya tıklayarak indirin.

Bu en son sürümünde packet limiti mevcuttur, ve buda korumaktadır.
Herkese İyi Oyunlar.
Java, Developer

zaferkaan1231

Intermediate

  • "zaferkaan1231" is male

Posts: 631

Date of registration: Jul 8th 2015

  • Send private message

7

Sunday, September 11th 2016, 8:26pm

Merhaba
Güzel Ve Yararlı Bir Konu
Nitrado Farkı :)
<<PowerfulCraft>>
Play.PowerfulCraft.Net
1.7.X - 1.8.X
Hub Server

xXxcCcJc

Trainee

  • "xXxcCcJc" is male

Posts: 608

Date of registration: Aug 30th 2016

Location: İstanbul

Occupation: Öğrenci

  • Send private message

8

Monday, September 12th 2016, 12:33am

Güzel bi forum.. Ama 1.9.x 1.10.x sürümdeki yeni itemler kullanılamıyor. Yine de teşekkürler.

Pluginer

Intermediate

  • "Pluginer" is male
  • "Pluginer" started this thread

Posts: 1,062

Date of registration: Feb 20th 2016

Location: Modena, Italya

Occupation: Öğrenci

  • Send private message

9

Monday, September 12th 2016, 2:03am

1.9.x ve 1.10.x versiyonunda yeni itemler zaten kullanılamaz.
yoksa 1.8 versiyonu ile çakışırdı ve belki 1.8 versiyonu ile giriş yapanlar hemen crash yiyebilirdi.
Java, Developer

  • "MD_Optional" is male
  • "MD_Optional" has been banned

Posts: 580

Date of registration: Mar 6th 2016

  • Send private message

10

Tuesday, September 13th 2016, 3:16pm

Güzel Olmuş :)
ITRADO ORUM

EnesAkkaya

Intermediate

  • "EnesAkkaya" is male

Posts: 1,583

Date of registration: Apr 16th 2016

  • Send private message

11

Tuesday, September 13th 2016, 4:09pm

Paylaşımınız için teşekkür ederiz. Yeni güncellemeleri bu konu üzerinden paylaşabilirsiniz.
Fakat bu koruma yeni çıkan ve çıkacak clientlere karşı koruyabilecek mi? Bunların testini de yapmalıyız! :)
YENİLER BİLMEZ! :)




12

Tuesday, September 13th 2016, 4:28pm

Mantıktan bakarsak bi yorma ihtimali var 100 packet ustu kabul etmiyorsa reddetmelidir cevap vermeledir yani buda cpu harcayabilir
Bloğumu Takip Etmek İstemezmisin >>Hemen Tıkla
Skript Dersleri | #1 >> Hemen Tıkla
SoloTurk™ Kimdir? >> Hemen Tıkla

Rate this thread